微视视频解析
微视无水印视频解析

接口地址: https://api.muxiaoguo.cn/api/weishi/

返回格式: JSON

请求方式: GET/POST

请求示例: https://api.muxiaoguo.cn/api/weishi?url=https%3A%2F%2Fh5.weishi.qq.com%2Fweishi%2Ffeed%2F7fZEijnCz1JBggqt5%2Fwsfeed%3Fwxplay%3D1%26id%3D7fZEijnCz1JBggqt5%26spid%3D8529346620708098048%26qua%3Dv1%5Fand%5Fweishi%5F6.9.0%5F588%5F312027000%5Fd%26chid%3D100081014%26pkg%3D3670%26attach%3Dcp%5Freserves3%5F1000370011

请求参数说明:

名称 必填 类型 说明
url String 微视分享链接(需要urlencode编码)

返回参数说明:

名称 类型 说明
author String 用户昵称
signature String 用户签名
title String 视频标题
avatar String 用户头像
imgurl String 视频封面
mp3name String 音乐名称
mp3url String 音乐URL
videourl String 视频链接

返回示例:

提示:提交的URL请使用urlencode编码再进行提交(之后会进行修复的),示例代码中有易语言Demo可供参考
{
    "code":200,
    "msg":"success",
    "data":{
        "author":"布朗",
        "signature":"90斤的布朗熊,给我个抱抱好吗",
        "title":"这是高手",
        "avatar":"http://pic200.weishi.qq.com/aa86bfe3b3804c3a8db4312916d8cover.jpg",
        "imgurl":"http://xp.qpic.cn/oscar_pic/0/55d15a4d617847f4808b074d50acpict/480",
        "mp3name":"You Know I'll Go Get",
        "mp3url":"http://v.weishi.qq.com/v.weishi.qq.com/shg_1047_1047_0bf2ruaxeaabceames6fmzpbndieoknac5sa.f0.mp4?dis_k=1c198cb7455122a8229afbca374d8dae&dis_t=1590941548&fromtag=0&personid=h5",
        "videourl":"http://v.weishi.qq.com/shg_1047_1047_0bf2ruaxeaabceames6fmzpbndieoknac5sa.f30.mp4?dis_k=a40b79b137d5860353ce640e98d83458&dis_t=1590941548&pver=1.0.0&fromtag=0&personid=h5&wsadapt=h5_0601001228_290454160_160237777_0_0_0_27_8_0_0_0_0_0&qua=v1_ht5_qz_3.0.0_001_idc_new&appver=30000&wsadapt=h5_0601001228_290454160_160237777_0_0_0_27_0_0_0_0_0_0&qua=v1_ht5_qz_3.0.0_001_idc_new&appver=30000"
    }
}

错误码格式说明:

名称 类型 说明

代码示例:

.版本 2
.支持库 spec

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 Apiurl, 文本型
.局部变量 Wsurl, 文本型
.局部变量 data, 文本型

' //调用了精易模块
Apiurl = “https://api.muxiaoguo.cn/api/weishi?url=”
Wsurl = 编码_URL编码 (“https://h5.weishi.qq.com/weishi/feed/73AvOKigI1Jy6v9YR/wsfeed?wxplay=1&id=73AvOKigI1Jy6v9YR&spid=1522239649708016&qua=v1_and_weishi_6.9.0_588_312027000_d&chid=100081014&pkg=3670&attach=cp_reserves3_1000370011”, 真, 真)
data = 编码_Utf8到Ansi (网页_访问 (Apiurl + Wsurl))
调试输出 (data) ' //输出结果
返回 (0) ' 可以根据您的需要返回任意数值